Paint.NET

documentation

Revision Date: 16 May 2015

Edit Menu

The Edit Menu commands cover navigation through the image history, clipboard commands, manipulation of the selected region and the selection itself.

Edit Menu Edit Menu

Edit Undo icon Undo

This undoes the most recent action that has affected the image open on the canvas, if any.

If multiple images are open simultaneously, Undo operates only on the one in the Editing window at the time the command is invoked.

This command can also be accessed via the History Window or via the keyboard shortcut Ctrl + Z.

Edit Redo icon Redo

This reverses the most recent action that has been 'undone', if any.

If multiple images are open simultaneously, Redo operates only on the one in the Editing window at the time the command is invoked.

This command can also be accessed via the History Window or via the keyboard shortcut Ctrl + Y.

Edit Cut icon Cut

The Cut command is used to remove a selected portion of the active layer AND store a copy of it in the clipboard.

Selections can be any shape or size and made with any of the selection tools or any combination of them.   Once Cut is invoked, the operation removes the selected pixels from the active layer and replaces them with transparent white pixels (RGB #FFFFFF with opacity/Alpha of zero).   The current selection outline is removed following the completion of the action (i.e. the selection is deselected).

This command can also be accessed via the keyboard shortcut Ctrl + X.

Edit Copy icon Copy

This command copies the selected region to the clipboard.  The selection remains in situ on the active layer.  The current selection also remains active.

Copy can be invoked from the keyboard via the Ctrl + C combination.

Edit Copy Merged icon Copy Merged

This command copies all the layers to the clipboard without having to use Image→Flatten first.

Edit Paste icon Paste

If there is an image in the clipboard, this command will paste it onto the active layer.  Pixels being pasted will overwrite existing pixels in the same location.   The pasted pixels will be selected following the paste operation and the Move Selected Pixels tool will automatically be activated.   This allows the pasted pixels to be moved, scaled or rotated with ease.

If the pasted image is too wide and/or too tall for the current canvas size, a prompt will appear asking if the canvas should be resized.   This quick shortcut to the Image → Canvas Size command allows a neat fit for the pasted image when it is larger than the current canvas.

Paste can be invoked from the keyboard via the Ctrl + V combination.

Paste Paste

Edit Paste into Layer icon Paste in to New Layer

This is similar to Paste, except that a new layer is created to house the clipboard image.   In this respect, the action is non-destructive and will not overwrite any existing pixels, though the layering characteristics of the image may lead to some pixels being obscured by the newly pasted ones.

The new layer is created immediately above the current active layer.  The newly created layer is made active prior to the paste operation being performed and retains the focus at the conclusion to the operation.

Paste in to a New Layer can be invoked from the keyboard via the Ctrl + Shift + V combination.

Edit Paste into New Image icon Paste in to New Image

This is similar to Paste, except that it first creates a brand new image, makes it active, then pastes the contents of the clipboard into it.   The new image will be exactly the same size as the clipboard image.

Paste in to a New Image can be invoked from the keyboard via Ctrl + Alt + V.

Edit Erase Selection icon Erase Selection

This command erases the currently selected region of the active layer.   All pixels that lie within the selected region are replaced with transparent white pixels (RGB #FFFFFF with opacity/Alpha of zero).   The selection outline is removed following the completion of the action (i.e. the selection is deselected).   The command can be invoked with the Delete key on the keyboard.

Edit Fill Selection icon Fill Selection

If there is a selection active, this command will fill it with the current Primary color.   The current selection remains active following the Fill operation.

The command can be invoked with the Backspace key on the keyboard.

Edit Invert Selection icon Invert Selection

If there is a selection active, this command will cause all pixels that are selected to be deselected, and vice-versa.

The keyboard shortcut for this command is Ctrl + I.

Edit Select All icon Select All

This causes the entire active layer to become selected.

The keyboard shortcut for this command is Ctrl + A.

Edit Deselect icon Deselect

Deselect forces all selected pixels to be deselected.  In other words, no pixels will remain selected.

The keyboard shortcut for the Deselect command is Ctrl + D.

Note

It is important to understand that when a selection is active in Paint.NET, all editing operations are clipped at the edge of the selection.   Under no circumstances do any editing operations extend outside of an active selection.

For example, if the Ellipse Select Tool is used to select a circular region in the middle of the active layer, nothing will be able to be drawn outside of the selection circle while it remains active.

Selection clipping

Effects (including the Text Tool as seen here) and Adjustments will be rendered as normal inside the selected area.