paint.net

documentation

Revision Date: 6 July 2016

Keyboard & Mouse Commands

Most commands in paint.net can be quickly accessed via the keyboard. For your convenience, all of the keyboard shortcuts are listed here.

If more than one tool shares the same shortcut, pressing the shortcut repeatedly will cycle through each of the tools in turn.  Digits shown like this - x3 - denote the number of times the key should be pressed to activate the tool group and cycle to the specific tool.

UI / Canvas Controls

Pan image (does not work while typing with the Text tool)

Hold Spacebar + drag with Left Mouse Button

Scroll up / down

Mouse Wheel up / down or PgUp / PgDn

Scroll left

Shift + Mouse Wheel up, Shift + PgUp or Home x 1

Scroll right

Shift + Mouse Wheel down, Shift + PgDn or End x 1

Scroll image to top left of editing window

Home x 2

Scroll top left image to center screen

Ctrl + Home

Scroll image to bottom right of editing window

End x 2

Scroll bottom right image to center screen

Ctrl + End

Zoom in / out

Ctrl + Mouse Wheel
Ctrl + - and +
Ctrl + 0 (sets actual size)
In the Status Bar drag the slider or type a value in the percentage text box
Options in the View Menu

Pan canvas

Spacebar + Left Mouse Button
Spacebar + Arrow keys

Pan canvas x 10

Spacebar + Ctrl + Arrow keys

Deselect active selection

Ctrl + D or Enter

Shift current tool per pixel

Arrow keys . These may not work with all tools

Shift current tool 10 pixels

Hold Ctrl + Arrow keys (may not work with all tools)

Show Menu Hotkey

Alt

Use Menu Hotkey

Alt + underlined letter in menu

Show / Hide Tools Window

F5

Show / Hide History Window

F6

Show / Hide Layers Window

F7

Show / Hide Colors Window

F8

Commit text or tool drawing to layer

Esc, Enter, Ctrl + D or Click Finish in Tool Bar

Tool Shortcuts

Rectangle Select

S

Lasso Select

S x 2

Ellipse Select

S x 3

Magic Wand

S x 4

Paint Bucket

F

Paintbrush

B

Pencil

P

Clone Stamp

L

Text

T

Shapes

O x 2

Move Selected Pixels

M

Move Selection

M x 2

Zoom

Z

Pan

H  (temporary activation: hold Spacebar + drag with Left Mouse Button / keyboard arrow keys)

Gradient

G

Eraser

E

Color Picker

K

Recolor

R

Line / Curve

O

Image List and Image Navigation

Next image

Ctrl + Tab

Previous image

Ctrl + Shift + Tab

Switch to image number X

Ctrl + X or Alt + X

Tool Bar

Decrease Brush Width by 1

[

Increase Brush Width by 1

]

Decrease Brush Width by 5

Ctrl + [

File Menu

Open File menu

Alt + F

New Image

Ctrl + N

Open Image

Ctrl + O

Close Image

Ctrl + W or Ctrl + F4

Save Image

Ctrl + S

Save Image As

Ctrl + Shift + S

Print

Ctrl + P

Exit paint.net

Alt + F4 or Alt + F then X

Edit Menu

Open Edit menu

Alt + E

Undo

Ctrl + Z

Redo

Ctrl + Y

Cut

Ctrl + X or Shift + Delete

Copy

Ctrl + C or Ctrl + Insert

Copy Merged

Ctrl + Shift + C

Paste

Ctrl + V or Shift + Insert

Paste into New Layer

Ctrl + Shift + V

Paste into New Image

Ctrl + Alt + V

Erase Selection

Delete

Fill Selection

Backspace

Invert Selection

Ctrl + I

Select All

Ctrl + A

Deselect active selection

Ctrl + D or Enter

View Menu

Open View menu

Alt + V

Zoom In

Ctrl + +

Zoom Out

Ctrl + -

Zoom to Window

Ctrl + B

Zoom to Selection

Ctrl + Shift + B

Actual Size

Ctrl + 0

Image Menu

Open Image menu

Alt + I

Crop to Selection

Ctrl + Shift + X

Resize

Ctrl + R

Canvas Size

Ctrl + Shift + R

Rotate 90° (clockwise)

Ctrl + H

Rotate 90° (counter-clockwise)

Ctrl + G

Rotate 180°

Ctrl + J

Flatten

Ctrl + Shift + F

Layers Menu

Open Layers menu

Alt + L

Add New Layer

Ctrl + Shift + N

Delete Layer

Ctrl + Shift+ Delete

Duplicate Layer

Ctrl + Shift + D

Merge Layer Down

Ctrl + M

Rotate / Zoom

Ctrl + Shift + Z

Layer Properties

F4

Adjustments Menu

Open Adjustments menu

Alt + A

Auto-Level

Ctrl + Shift + L

Black & White

Ctrl + Shift + G

Brightness / Contrast

Ctrl + Shift+ T

Curves

Ctrl + Shift + M

Hue / Saturation

Ctrl + Shift + U

Invert Colors

Ctrl + Shift + I

Levels

Ctrl + L

Posterize

Ctrl + Shift + P

Sepia

Ctrl + Shift + E

Effects Menu

Open Effects menu

Alt + C

Repeat last effect

Ctrl + F

Settings Dialog

Open Settings dialog

Alt + X

Help Menu

Open Help menu

Alt + H

Online documentation

F1

paint.net Search

Ctrl + E

Colors Window

Toggle visibility of window

F8

Swap Primary and Secondary colors

X

Switch active color

C

Selection Tools (except Magic Wand)

Rectangle Select

S

Lasso Select

S x 2

Ellipse Select

S x 3

Create selection

Drag + Left or Right Mouse Button

Add to selection

Ctrl + Drag + Left Mouse Button

Subtract from selection

Alt + Drag + Left Mouse Button

Invert selection mode

Ctrl + Drag + Right Mouse Button

Intersect selection mode

Alt + Drag + Right Mouse Button

Force Rectangle Select to square

Shift + Drag

Force Ellipse Select to circle

Shift + Drag

Move selection while dragging

Drag + Left + Right Mouse Button

Move a Copy of selection

Move Selected Pixels tool + Ctrl

Magic Wand Tool

Activate Magic Wand

S x 4

Create selection of like pixels

Left Mouse click

Add to selection

Ctrl + Left Mouse click

Subtract from selection

Alt + Left Mouse click

Invert a portion of selection

Ctrl + Right Mouse click

Intersect selection mode

Alt + Right Mouse click

Global selection

Shift + other Magic Wand action

Move Tools

Move Selected Pixels tool

M

Move Selection tool

M x 2

Resize the selection

Drag corner or edge nub.

Resize & keep proportions

Shift + drag corner nub

Move selection

Drag with Left Mouse Button when pointer is a four-way arrow

Rotate selection

Drag with Left Mouse Button when pointer is a double headed arrow or Drag with Right Mouse Button

Manipulate a copy of the selection (Move Selected Pixels Tool only)

Hold Ctrl while using the tool

Zoom Tool

Activate Zoom tool

Z

Zoom in

Click with Left Mouse Button

Zoom out

Click with Right Mouse Button

Pan while zoomed

Click and drag with Middle Mouse Button or Mouse Wheel

Pan Tool

Activate Pan tool

H

Pan the canvas

Click and drag with Left or Right Mouse Button or
Click and hold either mouse button + arrow keys

Reposition Pan tool

Move mouse or keyboard arrow keys

Paint Bucket

Activate Paint Bucket

F

Fill area with Primary color

Click with Left Mouse Button or Backspace

Fill area with Secondary color

Click with Right Mouse Button or Shift + Backspace

Global fill mode

Hold Shift in Contiguous mode

Contiguous fill mode

Hold Shift in Global mode

Gradient tool

Activate Gradient tool

G

Primary → Secondary gradient

Drag with Left Mouse Button

Secondary → Primary gradient

Drag with Right Mouse Button

Move start/end point

Drag either control nub

Swap gradient direction (i.e. swap color roles)

Click either nub with Right Mouse Button

Move gradient while drawing

Drag four arrow icon

Constrain gradient to 15 degree increments

Hold Shift while dragging either nub

Paint Brush

Activate Paintbrush tool

B

Draw in Primary color

Click or Drag with Left Mouse Button

Draw in Secondary color

Click or Drag with Right Mouse Button

Pencil tool

Activate Pencil tool

P

Draw in Primary color

Click or Drag with Left Mouse Button

Draw in Secondary color

Click or Drag with Right Mouse Button

Eraser tool

Activate Eraser tool

E

Erase an area

Click or Drag with either Mouse Button

Color Picker

Activate Color Picker

K

Set Primary color

Click with Left Mouse Button

Set Secondary color

Click with Right Mouse Button

Recolor tool

Activate Recolor tool

R

Recolor Secondary color with Primary

Drag with Left Mouse Button

Recolor Primary color with Secondary

Drag with Right Mouse Button

Clone Stamp tool

Activate Clone Stamp tool

L

Set source point

Ctrl + Click with Left Mouse Button

Copy pixels

Drag with Left or Right Mouse Button

Text tool

Activate Text tool

T

Temporarily hide cursor/nub

Hold Ctrl

Toggle move nub's visibility

Tap Ctrl

Commit text to layer

Esc or Click Finish in Tool Bar

Line/Curve tool

Activate Line/Curve tool

O

Start Cap style

, (comma key)

Line style

. (period key)

End Cap style

/ (forward slash key)

Move Line/Curve nubs

Drag nub with either Mouse Button or click & hold the nub and use the arrow keys

Drag entire Line/Curve

Drag four way arrow icon with Left Mouse Button

Move Line/Curve by 1px

Press any of the keyboard arrow keys

Move Line/Curve by 10px

Hold Ctrl and press any arrow key

Rotate Line/Curve

Drag with Right Mouse Button

Lock rotation to 15° increments

Hold Shift while rotating

Shape tool

Activate Shape tool

O x 2

Draw shape in Primary color

Drag with Left Mouse Button

Draw shape in Secondary color

Drag with Right Mouse Button

Cycle forward through shapes

A

Cycle backward through shapes

Shift + A

Move Shape nubs

Drag nub with either Mouse Button or click & hold the nub and use the arrow keys

Lock Shape height and width ratio

Hold Shift while dragging any nub

Drag entire Shape

Drag four way arrow icon with Left Mouse Button or position pointer inside Shape and drag with Left Mouse Button

Move Shape by 1px

Press any of the keyboard arrow keys

Move Shape by 10px

Hold Ctrl and press any arrow key

Rotate Shape

Drag with Right Mouse Button

Lock rotation to 15° increments

Hold Shift while rotating