paint.net

documentation

Revision Date: 19 April 2019

Glossary

.NET

A Microsoft framework which is required to run paint.net.

Acquire

Load an image from a scanner or camera.

Active layer

The layer which has the editing focus. It is highlighted in the Layers Window.

Actual Size

Sets the zoom level to 100%. Each pixel on the screen will correspond exactly with one pixel in the active layer.

Add (Union)

Selection mode which combines multiple selections into a single selection.

Add Noise

A Noise Effect which adds digital 'noise' to an image. Noise is similar to TV static.

Additive

A blend mode which has the effect of brightening pixels in the final composition.

Adjustment

A per-pixel filter used to change the colorization or transparency of pixels. Also one of the paint.net menus which contains these types of filters.

Alpha

The opacity value of a pixel which ranges from 0 (completely transparent) to 255 (completely opaque).

Antialiasing

The removal of jagged edges by subtle in-filling of intermediate pixels to even out the 'steps' between pixels.

ARGB (Alpha, Red, Green, Blue)

Alternative format for color information forming a single pixel. See BGRA.

Artistic

An Effect sub-menu. Artistic Effects mimic the traditional drawing mediums; ink, pencil and oil.

Auto-Level

An Adjustment used to equalize the range of colors in an image.

Bézier Curve

One of two types of curve used by the line tool. Béziers can be used create complex curves including loops.

BGRA (Blue,Green,Red,Alpha)

The four 8-bit color values used to define the colorization of a single pixel in paint.net.

Bit (Binary digit)

The most basic unit of computer data. A single bit has the capacity to be on or off.

Bitmap (*.bmp)

An image file format. File sizes are usually large.

Black & White

An Adjustment which desaturates an image, removing all color information and rendering the image in gray-scale.

Blend Mode

The way layers or pixels will be combined with those below them.

Blurs

An Effect sub-menu. Blurs defocus or soften images.

Brightness / Contrast

An Adjustment used to make an image brighter or darker (Brightness), or to change the difference between color tones (Contrast).

Brush Width

The diameter (in pixels) of the tip of the Paint Brush, Clone Stamp, Eraser, Line/Curve, Shapes and Recoloring tools.

Bulge

A Distort Effect which enlarges (or contracts) an area of an image.

Byte

A unit of digital information, most commonly consisting of eight bits.

Canvas

The virtual area which holds the current image.

Canvas Size

The pixel dimensions of the surface which holds an image. May be resized by absolute size or percentage (Image > Canvas Size).

Center Image

Relocate an image to the center of the editing window.

Classic paint.net

The free version of paint.net which must be manually installed after downloading from the paint.net website https://getpaint.net/download.html. Compare "Windows Store paint.net".

Clipboard

A software facility used for short-term data storage. Stored data can be transfered between documents or applications.

Clone Stamp

A tool which copies circular regions from one place to another.

Clouds

A Render Effect which creates configurable cloud-like textures.

CMYK (Cyan, Magenta, Yellow, Black)

A method of encoding color information. Used by the printing industry as it mimics the way inks are added onto (usually) white paper.

Color Burn

A blend mode which has the effect of making dark pixels darker while lighter pixels must be blended with other light colored pixels in order to remain bright.

Color Dodge

A blend mode where lighter pixels retain their brightness while darker pixels must be blended with other dark pixels in order to remain dark.

Color Picker

A tool which loads a pixel's color into the Primary or Secondary color slot.

Color Wheel

A region in the Colors Window where new colors are chosen by clicking the mouse.

Colors Window

The utility window where colors are selected and modified.

Commit text to layer

Stops the input of characters and commits the text to the layer as pixels.

Contiguous

A fill mode which tests pixel neighbors and colors them according to similarity to the source pixel.

Copy

Places a copy of the current layer or selection into the clipboard.

Copy Merged

Combines all the visible layers and copies them to the clipboard.

Create selection

To use any of the selection tools to form a selection.

Crop to Selection

Removes unselected portions of an image.

Crystalize

An Effect which mimics Pixelate, and also transforms the enlarged pixels into simple polygon shapes.

Curves

An Adjustment used to adjust the luminosity and/or RGB (Red, Green & Blue) color curves of an image.

Cut

Removes a region from an image after placing a copy of it on the clipboard.

Darken

A blend mode in which the darkest pixel of either the blend layer or the composition is used.

Dents

A Distort Effect which distorts the active layer or selection as if it was reflected in turbulent water.

Desaturate

To lower the intensity of colors.

Deselect

Removes the selection focus from all pixels.

Difference

A blend mode where the pixel intensity is subtracted from the composition pixel intensity. It results in darker colors.

Distort

An Effect sub-menu. The Effects warp, twist, transform or convolute an image.

DLL (Dynamic-Link Library)

The file format in which plugins are encoded.

DPI (Dots Per Inch)

A way of specifying how much information should be packed into a specified area when printing.

Drag

Click, hold and move the mouse.

Drawing Tools

Paintbrush, Pencil and Eraser tools.

Dynamic-Link Library

See DLL.

Edge Detect

A Stylize Effect which highlights edges in an image as if a strong light had been shone on it at an acute angle.

Edit Menu

One of the paint.net menus. It contains many basic editing operations like cutting and pasting and some selection tools.

Editing window

The area in paint.net where an image is placed for editing.

Effect

A tool which may alter the existing layer or create entirely new areas of color.

Ellipse Select

A tool used to create elliptical and circular selections.

Emboss

A Stylize Effect which generates a black and white image where the edges (areas of high contrast) have been given a three-dimensional highlight.

End Cap

The shape or style used at the end of a line or curve.

Erase Selection

Removes the current selection from an image.

Eraser

A brush-like tool which removes color information from pixels.

FAQ (Frequently Asked Questions)

A list of questions newcomers often ask. Compiled and pinned somewhere for ease of access.

File Menu

One of the paint.net menus. The menu items cover saving, loading and printing of files.

Filetypes

Plugins which add new file format options to the default load/save dialogs.

Fill Selection

Colors the current selection with the Primary or Secondary color.

Fill Styles

A number of predefined patterns which can be used to add texture when filling a region with color.

Fill Tools

Collective name for the Paint Bucket and Gradient tools.

Flatten

Merge all layers into a single layer.

Flood mode

The way neighboring pixels are treated when flooding an area with color. See Contiguous and Global.

Fragment

A Blur Effect in which multiple copies of the image are superimposed over the original.

Frosted Glass

A Distort Effect which transforms the original image as if it were being viewed through frosted glass.

Gaussian Blur

A Blur Effect which results in a defocusing of the original.

GB (Gigabyte)

One gigabyte is approximately 1000MB (10^9 or 1 000 000 000 bytes).

GIF (Graphics Interchange Format)

Image file format. Useful for low color images. Supports simple animations and on/off transparency on a per-pixel basis.

Global (Fill Mode)

A fill mode which colors non-adjacent pixels according to similarity to the source pixel.

Global (Selection Mode)

A selection mode which matches non-adjacent pixels according to similarity to the source pixel.

Glow (Blend Mode)

A Blend mode which brightens the composition by the amount of brightness in the blend layer.

Glow (Effect)

A Photo Effect which applies a brightening of lighter tones. Similar to a photo subject being subjected to strong back-lighting.

Gradient

A tool which creates patterns transitioning from one color to another.

Grayscale

A palette of colors ranging from Black to White. In paint.net there are 256 shades of gray.

GUI (Graphical User Interface)

See UI.

Hardness

A Toolbar option which determines how hard or soft the edge of a tool will be.

Hardware Acceleration

The use of computer hardware to perform functions more efficiently than software.

Height Map

A way of encoding height information into the pixels of an image. Often used to distort or shade another image.

Hexadecimal

Numbers expressed in base 16. Often used to express the components of a color.

History Window

The utility window where the editing steps are shown.

HSV (Hue,Saturation,Value)

An alternative to the RGBA/BGRA/ARGB color space. Colors are defined using the three terms Hue, Saturation & Value.

Hue

A shade of color. Hue is the clock-wise angle around the rim of the color wheel (starting from red).

Hue / Saturation

An Adjustment used to change the vividness of the colors in an image.

Image List

An area in the Toolbar where opened images are displayed as thumbnails.

Image menu

One of the paint.net menus. It contains editing actions which are applied to the entire image (i.e. all layers).

Import File

Allows the selection of an existing image which is copied onto the editing surface.

Ink Sketch

An Artistic Effect. Makes an image appear if the outlines were drawn with an ink pen and colored in with colored pencils.

Installer

Software which automates the installation of a product.

Intersect

A selection mode. When used with multiple areas, only overlapping areas are kept in the selection.

Invert 'Xor'

A selection mode. When used with multiple areas, overlapping areas are removed from the selection.

Invert Colors

An Adjustment which swaps a color for a shade from the opposite side of the Color wheel. Much like a photographic negative.

Invert Selection

Swaps the selection focus from any selected pixels to any unselected pixels.

JPG / JPEG (Joint Photographic Experts Group)

Image file format. JPGs are superior at making photos smaller by allowing the loss of minor detail.

Julia Fractal

A Render Effect which recreates the Julia fractal in the active layer or selection.

kB (Kilobyte)

One kilobyte is approximately 1000 bytes (10^3). Because computers are binary based, the correct figure is actually 1024 bytes (2^10).

Keyboard shortcuts

Combinations of keyboard keys which perform a particular action.

Lasso Select

A tool used to create freehand selections.

Layer Properties

The dialog where the layer name, blend mode, visibility and opacity can be altered.

Layers menu

One of the paint.net menus. It contains editing actions which are confined to the active layer.

Layers Window

The utility window where a composite image's individual layers are shown.

Levels

An Adjustment used to change the color range and gamma index of an image.

Lighten

A blend mode where the lightest pixel of either the blend layer or the composition is used.

Lightness

See Value.

Line / Curve Tool

A tool for creating lines and curves.

Line Style

The styling used to render the body of a line or curve.

Magic Wand Tool

A tool used to select similar pixels or regions.

Mandelbrot Fractal

A Render Effect which recreates the Mandelbrot fractal in the active layer or selection.

MB (Megabyte)

One megabyte is approximately to one million (10^6 or 1 000 000) bytes of information.

Median

A Noise Effect which applies a nonlinear filter to either reduce digital noise or blur the original.

Menu Bar

The area above the Toolbar containing menus.

Merge Layer Down

Merges one layer into the one immediately below it in the Layers Window.

Morphology

A Distort Effect encompassing Erode and Dilate image processing operations.

Motion Blur

A Blur Effect which adds the illusion of sideways motion to an image.

Move Selected Pixels

A tool which allows the reshaping and/or rotation of pixels in the active layer or selection.

Move Selection

A tool which reshapes or moves the selection outline.

Move Tool

Commonly used name for the Move Selected Pixels tool.

Move Tools

One of two tools used to move pixels (Move Selected Pixels) or the selection outline (Move Selection).

MSI (Microsoft Installer)

A Windows installer package.

Multiply

A blend mode where each pixel's RGB component intensity is multiplied with the pixel value from the composition.

Negation

A blend mode which makes the colors brighter and alters their hue.

Noise

An Effect sub-menu. Noise Effects can be used to add or remove digital "noise" from an image. Digital noise can be likened to TV static.

Normal

A blend mode where each pixel in the layer is blended with the composition depending on its alpha value.

Nub

A control point which can be dragged to change the shape of a selection, selection outline, Shape or tool.

Object

A group of pixels with an edge that abuts transparent pixels.

Oil Painting

An Artistic Effect which transforms an image as though it was hand painted in oils.

Online Documentation

The official paint.net documentation.

Opacity (aka Alpha)

The amount of transparency in a color, pixel or layer.

Outline

A Stylize Effect which enhances edges found in an image by tracing around them with an outline of requested radius.

Overlay

A blend mode which acts like Multiply for darker colors. For lighter colors, this acts like Screen.

Overscrolling

The ability to pan an image past the edge of the editing window.

Overwrite

A blend mode where new pixel data completely replaces old pixel data.

Paint Bucket

A tool used to fill areas with the Primary or Secondary color.

paint.net Search

A custom Google search which returns results from many online resources devoted to paint.net.

paintdotnet: protocol

A method of launching the app so that command-line parameters can be specified.

Paintbrush

A tool used to create swathes in a single color or hue.

Palette

A predefined list of colors. In paint.net a palette can hold 96 colors.

Pan

Move an image horizontally and/or vertically.

Paste

Insert the contents of the clipboard into the active layer or selection.

Paste into New Image

Pastes an image in the clipboard onto a new canvas the same size.

Paste into New Layer

Pastes an image in the clipboard into a new layer in the current image.

PDF (Portable Document Format)

A device-independent document format.

PDN (Paint Dot Net)

Native paint.net file format. It preserves the layer structure and pixel data. On the forum PDN is an abbreviation for "paint.net".

Pencil

A tool which colors individual pixels. Useful for or drawing thin freehand lines.

Pencil Sketch

An Artistic Effect which transforms an image to appear as though it were sketched with a pencil.

Photo

An Effect sub-menu. Photo Effects are used to modify and enhance digital photographs.

Photo Tools

Collective name for the Color Picker, Clone Stamp and Recolor tools.

Pixel Grid

A pixel sized grid used as a visual aid to identify individual pixels. Only available at 200% or higher zoom levels.

Pixelate

A Distort Effect which greatly reduces detail by enlarging regularly sampled pixels.

Plugin, plugins

Third-party developed Effects and Adjustments which enhance and expand the paint.net tool set.

PNG (Portable Network Graphics)

Image file format. Lossless. Supports a full Alpha (transparency) channel.

Polar Inversion

A Distort Effect that applies a transformation between Cartesian and Polar coordinate systems.

Posterize

An Adjustment which reduces the number of color values that can be assigned to a pixel.

Primary Color

One of two color slots which hold a color, hue or shade for quick use.

Radial Blur

A Blur Effect which applies the illusion of circular motion to an image.

Rasterization

The collective name for antialiasing and aliasing.

RAW

An image file format. A raw file is the image as seen and recorded by a digital camera's sensor with minimal processing.

Recolor Tool

A tool which changes one color (or shades) into another color (or shades).

Rectangle Select

A tool used to create rectangular selections.

Red Eye Removal

A Photo Effect which removes flash induced red eye from photos.

Redo

Restores the last action removed with Undo.

Reflect

A blend mode used to add shiny objects or areas of light.

Relief

A Stylize Effect which enhances edges in an image.

Remove Noise

A Noise Effect which removes digital 'noise' from an image.

Render

An Effect sub-menu. Render Effects create new patterns, colors and objects.

Repeat last effect

Repeats the last used Effect with the same configuration or parameters.

Replace (Selection Mode)

New selections will replace any and all previous selection(s).

Resize

Change the dimensions of an image.

Rick Brewster

Paint.net developer, and a good guy!

Rotate / Zoom

A tool which can rotate, tilt, pan and zoom the active layer or selection.

Ruler

A measurement aid. When enabled, paint.net shows measurement guides along the top and left edges of the editing window.

Sampling mode

Where pixels are selected from. Sampling can be restricted to the active layer or taken from the composite image (all visible layers).

Sampling size

How large an area will be used to sample pixels.

Saturation

The intensity of a color. Saturation can be thought of as the distance from the center of the color wheel to the given color.

Save

Saves the current image using the existing filename and file format (where possible). Keyboard shortcut is Ctrl + S.

Save As...

Saves a copy the current image by allowing a new filename, location and file format to be specified.

Screen

A blend mode which is used to make pixels brighter, with black being effectively transparent.

Scroll

Move an image horizontally or vertically.

Secondary Color

One of two color slots which hold a color, hue or shade for quick use.

Select All

Makes the entire active layer into a selection.

Selection

A grouping of pixels highlighted so that they can be processed independently of any unselected pixels.

Selection modes

The different ways successive selections interact. The modes are Replace, Add (Union), Subtract, Intersect and Invert (Xor'').

Selection Tools

One of four tools used to make selections (Rectangle select, Lasso select, Ellipse select and Magic Wand).

Sepia

An Adjustment which mimics an aged photograph by rendering the image in black & white, then adding a sepia tone.

Set Primary color

Change the color in the first color slot.

Set Secondary color

Change the color in the second color slot.

Settings Dialog

A dialog containing many options for configuring paint.net.

Shapes

Predefined line drawings which can be quickly added to an image.

Shapes Tool

A tool which applies predefined line drawings to the active layer or selection.

Sharpen

A Photo Effect used to reduce softness in an image.

Soften Portrait

A Photo Effect used to soften images by adding a subtle glow filter.

Spline Curve

One of two type of curve used by the line tool. The path of a spline always passes through the control points.

Sprite Sheet

An image file containing multiple small images in a tiled arrangement. Used to compose animations from a single source file.

Start Cap

The shape or style used at the start of a line or curve.

Status Bar

An information area at the foot of a UI.

Stylize

An Effect sub-menu. Stylize Effects produce changes to an original based on edge detection.

Subtract (Selection Mode)

Newly defined areas are removed from previously created selection(s).

Surface Blur

A Blur Effect used to reduce soft details or noise in an image while retaining most edge details and contrast.

TB

One terabyte is approximately one trillion bytes (10^12 or 1 000 000 000 000 bytes = 1000GB).

Text and Shape Tools

Collective name for the Text tool, Line/Curve tool and Shapes tool.

Text Rendering Modes

Three options which subtly change the way characters are rendered using the Text tool.

Text tool

A tool which allows text to be typed directly onto an image.

Tile

Repeat an image horizontally and/or vertically in order to fill available space.

Tile Reflection

A Distort Effect which makes the image appear as if reflected in a wall of mirrored tiles.

Tolerance

A numerical figure representing the similarity or dissimilarity between pixels.

Tone

An alternative way of expressing the lightness or luminosity of a color.

Tool Bar

An area above the editing surface where quick-use icons and tool options are shown.

Tools Window

The utility window where Tools may be selected by clicking with the mouse.

Turbulence

A Render effect which generates a colored bitmap based on the Perlin Noise function. The Effect is not unlike the Clouds Effect.

Twist

A Distort Effect which mimics winding the image around a skewer placed through the viewing screen.

UI (User Interface)

A window or dialog which accepts user input.

Undo

Reverse the last editing operation.

Unfocus

A Blur Effect which applies a dreamy or "unfocused" look to the image.

Utility Window

One of the four child windows: Tools, History, Layers and Colors.

Value

In HSV: The apparent brightness of a color.

View menu

One of the paint.net menus. It contains options for how the current image is displayed.

View Tools

Collective name for the Zoom and Pan tools.

Visibility

The display state of a layer or window.

Windows Store paint.net

The paid version of paint.net purchased from the Windows Store.  The paid version features easy installation, automatic updates & improved reliability. Compare "Classic paint.net".

Xor

A blend mode useful for finding differences in an image.

Zoom Blur

A Blur Effect which gives the appearance of motion towards the subject.

Zoom in / out

Expand or contract the view size of an image.

Zoom to Selection

Increases the view size of an active selection until the bounding rectangle reaches the limit of the viewable area.

Zoom to Window

Expands the view size of an image to the lesser of 100% size or the bounds of the editing window.