paint.net

documentation

Revision Date: 19 April 2019

Tool Bar

The Tool Bar contains buttons for accessing many common actions, view options, and controls for configuring how many of the tools interact with the image.

Tool Bar
Tool Bar

Common Actions

Common Action Buttons
Common Action Buttons

These buttons allow quick access to many common actions.

From left to right, they are New Image, Open (existing image), Save, Print, Cut, Copy, Paste, Crop, Deselect, Undo, and Redo.  These actions can also be found in the File and Edit menus.

View Controls

The next two buttons toggle the visibility of the Pixel Grid and the Rulers, respectively.

Pixel Grid Pixel Grid

The Pixel Grid overlays the current image with a grid where each cell is exactly one pixel in size.  The Pixel Grid is particularly useful when zoomed-in on an image and precise per-pixel editing is required.

The same icon can be used to toggle the grid off again. There is a corresponding menu command to enable or disable the grid in the View menu.

Note

The Pixel Grid is not visible below 200% magnification.

Rulers Rulers

This icon shows or hides rulers along the top and left edges of the image canvas.

The Rulers can help when aligning image elements, making measurements or adjusting an image to a specific size. The rulers are always set to the current Units of Measurement. These units are able to be changed via the View menu or the Status Bar.

When a selection is active, its bounding rectangle will be highlighted in the rulers, making it easier to measure. The cursor position is also shown in the rulers making it easier to accurately apply other tools.

Rulers
Rulers

There is a corresponding menu command in the View menu.

Tool Choice

The second row of the Tool Bar starts with a drop-down list where tools can be selected.  Clicking on the menu opens a vertical list of possible tools. This control is provided to augment the Tools Window in the case that the window is closed or obscured.

Tool drop-down List
Tool drop-down List

Tool Configuration

After the Tool button, the rest of the second row contains controls that configure the current tool.

Note

Some tool options in the Tool Bar can be altered by hovering the mouse over the control and using the Mouse Wheel (not the Tolerance). Generally these controls will have a white background.
The Brush Width has additional icons to increment and decrement the value and keyboard shortcuts are also assigned; [ and ].

Shapes, Brush, Style, and Fill

Shapes, Brush, Style, and Fill
Shapes, Brush, Style and Fill

The first two options shown are specific to the new Shapes Tool. These are covered in the Shapes Tool section.

Several tools use Brush Width, Style and Fill options. Here the width of the brush and line style can be selected. If a fill is also selected, both the Primary and Secondary colors will be used to render the pattern.

Selection Tools

Selection Tools
Selection Tools

The "Selection Mode" section of the Tool Bar allows quick access to the different ways that selections can be combined. These controls are common to all the Selection tools.

When a selection is created with one of the Selection tools any existing selection will be replaced if the Replace mode is used. If Add mode is used, new selections will be added to the original region. Subtract removes new selections from the original region. The Intersect mode keeps those areas common to multiple selections while the Invert mode excludes common areas from multiple selections.

To find out more about these selection modes, visit this page Selection Modes.

The next option in this section of the is Tool Bar sets the style of the selection shape.  The options are Normal (freehand), Fixed Size and Fixed Ratio selection drawing for the Rectangle Select tool.  The latter two styles are useful when cropping to a specific size (e.g. 4" x 3") area or to a fixed ratio (e.g. 16x10).

Text

Text
Text Options

This section of the Tool Bar is used only by the Text Tool. Options found here configure the font family, size, style, and alignment of text.

Gradient

Gradient
Gradient Options

The Gradient Tool has seven different gradient types. It also has options to operate in either color mode (gradients will be rendered as a blend from the Primary to the Secondary colors), or a special transparency mode (gradients will be rendered in the Alpha channel). This mode allows images to be blended or faded together.

Magic Wand, Paint Bucket, and Recolor

Magic Wand, Paint Bucket, and Recolor
Magic Wand, Paint Bucket, and Recolor Options

The Flood Mode affects only the Magic Wand Tool and Paint Bucket Tools.  See the sections on these tools for a description of how the Flood Mode works.

The Tolerance setting affects how many other pixels the Magic Wand Tool, Paint Bucket and the Recolor Tools affect in their operation. See the sections on these tools for a description of how the Tolerance works.

Color Picker

Color Picker
Color Picker

The Color Picker can be configured to examine either the layer or image (Sampling Mode). In addition, the Sampling size can also be set to one of six preset sizes via the Tool Bar.

There is a setting to automatically switch to another tool following use of the Color Picker. There are three options: Do Not Switch tool(default - the Color Picker tool will remain active), Switch to Previous tool and Switch to Pencil Tool. The selected behavior occurs following a click on the canvas with the Color Picker.

Move Selected Pixels

Move Pixels
Move Selected Pixels

The Move Selected Pixels tool can be configured to use either Bilinear (smooth) or Nearest Neighbor (pixelated)" (nearest neighbor) resampling. The Bilinear/Smooth quality is usually preferable unless there is a specific need for pixelated quality.

Rasterization, Blend Modes & Selection Clipping

Many tools are affected by these options.

Rasterization, Blend Modes and Selection Clipping
Rasterization, Blend Modes & Selection Clipping

To use these split-buttons, either click on the icon to toggle its state or click on the down arrow to open a submenu where the options can be selected.

Rasterization

Antialiasing enabled/disabled split button
Enable or disable tool antialiasing.

Rasterization affects how drawing is performed on a per-pixel basis with regard to the edge of the tool. In other words, it determines if the drawing will have antialiasing enabled or disabled. If enabled, the edges of the tool path will be smoothed. If disabled, the edges of the path of the tool will be snapped to the nearest pixel. A jagged or stepped appearance will result.

Example - Antialiasing

Rasterization Example

The circle on the left was drawn with antialiasing enabled. The one on the right was drawn with antialiasing disabled. The right circle is noticeably more "jagged" in its appearance:

Tool Blend Modes Blend Modes

The next control (also a split-button) controls the type of blending the tool will use.

Tool Bar Blend modes
Tool Bar Blend Modes

When in use, a Blend Mode will mimic the tool being applied to a layer immediately above the active layer and the result immediately merged into the active layer.

For more information on the Blend Modes, see the Blend Modes section.

Selection Clipping Mode

Selection Clipping
Selection Clipping

New to paint.net is the Selection Clipping Mode split button. This determines if the active selection should be aliased (pixelated) or antialiased (smoothed). If Pixelated selection quality is chosen the selection boundary will be snapped to the nearest pixel, resulting in a jagged or stepped appearance. If Antialiased selection quality is chosen the selection boundary will be antialiased so the boundary is smoother.

Finish button

Finish Button
Finish Button

Many tools and editing options remain "active" until the Finish control is clicked. The Finish button commits the shape, text, tool or operation to the canvas and relinquishes the editing mode that enables many tools and operations to be adjusted "live".

Tip

The keyboard shortcut for the Finish button is the Enter key.